Upstream Provider Issues
Incident Report for Stax Cloud
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 16:24 AEST
Monitoring
We will continue to monitor the situation
Posted Jun 17, 2021 - 12:39 AEST
Investigating
Due to upstream AWS issues in us-east-2 Stax users may experience degraded performance in the US1 region of Stax and problems with AWS Account management.
Posted Jun 17, 2021 - 10:59 AEST
This incident affected: US1 (Stax AWS Account Hardening).